OpenVZ Forum


Home » General » Support » Multicast between VEs
Multicast between VEs [message #14593] Tue, 03 July 2007 07:32 Go to next message
ataraxis is currently offline  ataraxis
Messages: 19
Registered: August 2006
Junior Member
Hi,

i have a question regarding multicast (i am new to multicast):

I use the following commands to test multicast:
iperf -s -B 224.0.66.66 -u (server)
iperf -c 224.0.66.66 -u (client)


It only works within the same VE.
It does not work between different VEs.
It does not work with a HN.
It does not work between HN / VE (and other way around).
It does not work between different HNs.

Any ideas what to test?

This is a debian box with custom kernel config (2.6.18-028stab035-1-openvz).

Thanks,
Ataraxis

Re: Multicast between VEs [message #14618 is a reply to message #14593] Tue, 03 July 2007 13:23 Go to previous messageGo to next message
Andrey Mirkin is currently offline  Andrey Mirkin
Messages: 193
Registered: May 2006
Senior Member
Can you please describe your network configuration (ip a ls, ip ro ls in VE and HN). Do you use venet or veth device in VE?

Andrey Mirkin
http://static.openvz.org/userbars/openvz-developer.png
Re: Multicast between VEs [message #14619 is a reply to message #14618] Tue, 03 July 2007 13:47 Go to previous messageGo to next message
ataraxis is currently offline  ataraxis
Messages: 19
Registered: August 2006
Junior Member
Quote:

(ip a ls, ip ro ls in VE and HN).


HN
ip a ls
2: eth0: <BROADCAST,MULTICAST,UP,10000> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:14:22:fe:7d:d8 brd ff:ff:ff:ff:ff:ff
    inet XXX.YYY.ZZZ.253/27 brd XXX.YYY.ZZZ.255 scope global eth0
4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000
    link/ether 00:14:22:fe:7d:d9 brd ff:ff:ff:ff:ff:ff
6: lo: <LOOPBACK,UP,10000> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
1: venet0: <BROADCAST,POINTOPOINT,NOARP,UP,10000> mtu 1500 qdisc noqueue
    link/void


ip ro ls
224.0.66.66 dev eth0  scope link
XXX.YYY.ZZZ.248 dev venet0  scope link
XXX.YYY.ZZZ.217 dev venet0  scope link
XXX.YYY.ZZZ.216 dev venet0  scope link
XXX.YYY.ZZZ.213 dev venet0  scope link
XXX.YYY.ZZZ.245 dev venet0  scope link
XXX.YYY.ZZZ.212 dev venet0  scope link
XXX.YYY.ZZZ.246 dev venet0  scope link
XXX.YYY.ZZZ.215 dev venet0  scope link
XXX.YYY.ZZZ.247 dev venet0  scope link
XXX.YYY.ZZZ.214 dev venet0  scope link
XXX.YYY.ZZZ.211 dev venet0  scope link
XXX.YYY.ZZZ.243 dev venet0  scope link
XXX.YYY.ZZZ.210 dev venet0  scope link
XXX.YYY.ZZZ.224/27 dev eth0  proto kernel  scope link  src XXX.YYY.ZZZ.253
224.0.0.0/4 dev eth0  scope link
default via XXX.YYY.ZZZ.225 dev eth0


VE

ip a ls
1: lo: <LOOPBACK,UP,10000> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
3: venet0: <BROADCAST,POINTOPOINT,NOARP,UP,10000> mtu 1500 qdisc noqueue
    link/void
    inet 127.0.0.1/32 scope host venet0
    inet XXX.YYY.ZZZ.210/32 scope global venet0:0


ip ro ls
192.0.2.1 dev venet0  scope link
default via 192.0.2.1 dev venet0


Quote:

Do you use venet or veth device in VE?

venet
Re: Multicast between VEs [message #14683 is a reply to message #14619] Thu, 05 July 2007 15:42 Go to previous message
Andrey Mirkin is currently offline  Andrey Mirkin
Messages: 193
Registered: May 2006
Senior Member
You need to setup veth networking inside your VE.
Also you will need to create a bridge on HN and add veth device and HN's eth0 device to it.

http://wiki.openvz.org/Virtual_Ethernet_device


Andrey Mirkin
http://static.openvz.org/userbars/openvz-developer.png
Previous Topic: Error message creating when creating VPS.
Next Topic: *SOLVED* vzctl restart from crontab
Goto Forum:
  


Current Time: Thu Feb 02 17:13:41 GMT 2023

Total time taken to generate the page: 0.00752 seconds