OpenVZ Forum


Home » General » Support » *BUG REPORTED* Migration error: iptables-restore exited with 1
*BUG REPORTED* Migration error: iptables-restore exited with 1 [message #14198] Tue, 19 June 2007 06:40 Go to next message
ugob is currently offline  ugob
Messages: 271
Registered: March 2007
Senior Member
Hi,

I get the following error when I try to migrate one VE to another server.

[root@source .ssh]# vzmigrate -v --online 192.168.2.17 107
OPT:-v
OPT:--online
OPT:192.168.2.17
Starting online migration of VE 107 on 192.168.2.17
OpenVZ is running...
    Loading /etc/vz/vz.conf and /etc/vz/conf/107.conf files
    Check IPs on destination node: 192.168.2.207
Preparing remote node
    Copying config file
107.conf                                      100% 1799     1.8KB/s   00:00
Saved parameters for VE 107
    Creating remote VE root dir
    Creating remote VE private dir
Initializing remote quota
    Quota init
    Turning remote quota on
Syncing private
Live migrating VE
    Suspending VE
Setting up checkpoint...
        suspend...
        get context...
Checkpointing completed succesfully
    Dumping VE
Setting up checkpoint...
        join context..
        dump...
Checkpointing completed succesfully
    Copying dumpfile
dump.107                                      100%   46MB   6.5MB/s   00:07
    Syncing private (2nd pass)
Syncing 2nd level quota
    Dumping 2nd level quota
    Copying 2nd level quota
quotadump.107                                 100%   21     0.0KB/s   00:00
    Load 2nd level quota
    Undumping VE
Restoring VE ...
Starting VE ...
vzquota : (warning) Quota is running for id 107 already
VE is mounted
        undump...
Adding IP address(es): 192.168.2.207
Setting CPU units: 7000
Error: undump failed: Invalid argumentStopping VE ...

Restoring failed:
iptables-restore exited with 1
rst_restore_net: -22
VE start failed
VE was stopped
VE is unmounted
Error:  Failed to undump VE
Resuming...
arpsend: 192.168.2.207 is detected on another computer : 00:d0:b7:c8:44:65
vps-net_add WARNING: arpsend -c 1 -w 1 -D  -e 192.168.2.207 eth0 FAILED
vzquota : (error) Quota is not running for id 107


I restarted vz on the destination... in vain. The destination is a fresh install of CentOS 4 and openvz.


Please read the manual before asking questions:
http://download.openvz.org/doc/OpenVZ-Users-Guide.pdf

Please have a look at the wiki before asking questions:
http://wiki.openvz.org/Main_Page

[Updated on: Thu, 21 June 2007 10:54] by Moderator

Report message to a moderator

Re: Migration error - Quota is not running [message #14199 is a reply to message #14198] Tue, 19 June 2007 06:44 Go to previous messageGo to next message
ugob is currently offline  ugob
Messages: 271
Registered: March 2007
Senior Member
I tried without the --online and it worked.

Please note that my /vz is not at /vz, but at /home/vz/ on the source server. On the destination server, the VM got migrated to /home/vz/ correctly when not using the --online option.

Regards,

Ugo


Please read the manual before asking questions:
http://download.openvz.org/doc/OpenVZ-Users-Guide.pdf

Please have a look at the wiki before asking questions:
http://wiki.openvz.org/Main_Page
Re: Migration error - Quota is not running [message #14205 is a reply to message #14198] Tue, 19 June 2007 08:12 Go to previous messageGo to next message
Andrey Mirkin is currently offline  Andrey Mirkin
Messages: 193
Registered: May 2006
Senior Member
The migration process failed not due to quota.
It is failed because of this:
Error: undump failed: Invalid argumentStopping VE ...

Restoring failed:
iptables-restore exited with 1
rst_restore_net: -22


Can you give an access to this nodes to investigate this issue? If you can, then please post it via PM.


Andrey Mirkin
http://static.openvz.org/userbars/openvz-developer.png
Re: Migration error - Quota is not running [message #14236 is a reply to message #14205] Wed, 20 June 2007 11:29 Go to previous messageGo to next message
Andrey Mirkin is currently offline  Andrey Mirkin
Messages: 193
Registered: May 2006
Senior Member
After some investigation on your node I have found that some iptables modules are not loaded on destination node.

On source node in /etc/vz/vz.conf we have:
IPTABLES="ipt_REJECT ipt_tos ipt_TOS ipt_LOG ip_conntrack ipt_limit ipt_multiport iptable_filter iptable_mangle ipt_TCPMSS ipt_tcpmss ipt_ttl ipt_length ipt_state iptable_nat ip_nat_ftp"

On destination node we have:
IPTABLES="ip_tables ipt_REJECT ipt_tos ipt_limit ipt_multiport iptable_filter iptable_mangle ipt_TCPMSS ipt_tcpmss ipt_ttl ipt_length"

After changing this value on dst node and restarting vz service I was able to migrate this VE.


Andrey Mirkin
http://static.openvz.org/userbars/openvz-developer.png
Re: Migration error - Quota is not running [message #14244 is a reply to message #14236] Wed, 20 June 2007 12:17 Go to previous messageGo to next message
Vasily Tarasov is currently offline  Vasily Tarasov
Messages: 1345
Registered: January 2006
Senior Member
Andrey, probably we should add the check of required modules in vzmigrate?..

Vasily.
Re: Migration error - Quota is not running [message #14251 is a reply to message #14244] Wed, 20 June 2007 13:44 Go to previous messageGo to next message
Andrey Mirkin is currently offline  Andrey Mirkin
Messages: 193
Registered: May 2006
Senior Member
Yes, we should definitely add this check.

Andrey Mirkin
http://static.openvz.org/userbars/openvz-developer.png
Re: Migration error - Quota is not running [message #14277 is a reply to message #14251] Thu, 21 June 2007 10:53 Go to previous messageGo to next message
Vasily Tarasov is currently offline  Vasily Tarasov
Messages: 1345
Registered: January 2006
Senior Member
Ok, I created a bug report in order not to forget about the problem: http://bugzilla.openvz.org/show_bug.cgi?id=631

Thanks.
Re: Migration error - Quota is not running [message #14280 is a reply to message #14277] Thu, 21 June 2007 12:36 Go to previous message
ugob is currently offline  ugob
Messages: 271
Registered: March 2007
Senior Member
Cool thanks Smile.

Please read the manual before asking questions:
http://download.openvz.org/doc/OpenVZ-Users-Guide.pdf

Please have a look at the wiki before asking questions:
http://wiki.openvz.org/Main_Page
Previous Topic: *SOLVED* vzpkgcache leaving directories
Next Topic: *BUG REPORTED* uncharging too much (othersockbuf) in 2.6.18-028test018.1+31-openvz-smp
Goto Forum:
  


Current Time: Thu Feb 02 17:07:50 GMT 2023

Total time taken to generate the page: 0.00730 seconds