OpenVZ Forum


Home » General » Support » 2 different networks on same VE
2 different networks on same VE [message #49036] Thu, 28 February 2013 10:19 Go to next message
TheGreatDoc is currently offline  TheGreatDoc
Messages: 3
Registered: February 2013
Location: España
Junior Member
From: *tvt-datos.es
Hi all,

I have a HN with 2 NIC in different subnets.

eth0 is 84.232.ab.8
eth1 is 172.20.20.253

Both networks works well if I only set one ip on the VE, but if I try to set both, the second one will not route.

Example.

VE with 172.20.20.252 will work perfectly with my internal network
VE with 84.232.ab.55 will work perfectly with my internal network

But, if I setup a VE with Primary IP 172.20.20.252 and Secondary 84.232.ab.55 only 172.20.20.252 will work, while 84.232.ab.55 will only be able to ping or communicate with HN.

If I switch primary and secondary, being 84.232.ab.55 primary ip address and 172.20.20.252 secondary, 84.232.ab.55 will work and 172.20.20.252 will only ping/communicate with HN.

System is a debian with Linux virt2 2.6.32-5-openvz-686

I also need to say I have one VE with IPv4 and IPv6 address and both work well.

In Attachment are the info about rules, routes, etc...
  • Attachment: openvz.txt
    (Size: 8.54KB, Downloaded 132 times)
Re: 2 different networks on same VE [message #49076 is a reply to message #49036] Fri, 15 March 2013 10:04 Go to previous message
TheGreatDoc is currently offline  TheGreatDoc
Messages: 3
Registered: February 2013
Location: España
Junior Member
From: *tvt-datos.es
No ideas on what can be wrong in my configuration?
Is this not possible to do with openvz?

Thanks in advance
Previous Topic: Can veth in CT0 send all packets to virtual ethernet device in CT
Next Topic: Ressources usage seems strange
Goto Forum:
  


Current Time: Thu Oct 30 15:09:00 GMT 2014