OpenVZ Forum


Home » General » Support » empty precreated templates?!?!
icon9.gif  empty precreated templates?!?! [message #31902] Sun, 13 July 2008 05:44 Go to next message
roland is currently offline  roland
Messages: 14
Registered: May 2008
Location: leb
Junior Member
Hi all,

i previously had problems with the wrong type of openvz kernel used, i formated my box with suse 10.2 again and i used the following kernel:
http://download.openvz.org/kernel/branches/sles10-2.6.16/027 stab028.3/kernel-ovzpae-2.6.16.60_027stab028.3-0.23.i686.rpm

after installation, i tried creating using a precreated Suse template which is the following :

http://download.openvz.org/template/precreated/opensuse-10-i 386-default.tar.gz


i could create/start the VE now normally though with one prob!

theres no Yum, apt-get,wget in it!
its empty!
i tried downloading rpms through the node to the root file on the ve, and ther rpm -Uhv inside.. but theres a whole lot of dependencies!
i managed to get a few by installing a few packages, but theres a lot more!

is it normal to have a template without such crucial elements?!
or is it some bug! or..!

the reason im asking this, is tht im looking to install mysql,tomcat,java, and another specific rpm tht i wanna work on!


any advice on how to solve this issue would be appreciated:)
thanks for your help so far..

[Updated on: Sun, 13 July 2008 05:52]

Report message to a moderator

Re: empty precreated templates?!?! [message #31910 is a reply to message #31902] Mon, 14 July 2008 07:40 Go to previous messageGo to next message
maratrus is currently offline  maratrus
Messages: 1495
Registered: August 2007
Location: Moscow
Senior Member
Hi,

why don't you try using yast?
Re: empty precreated templates?!?! [message #31912 is a reply to message #31910] Mon, 14 July 2008 09:47 Go to previous messageGo to next message
roland is currently offline  roland
Messages: 14
Registered: May 2008
Location: leb
Junior Member
i'm actually having trouble with yast, it simply hangs when i open it.
and i honestly dont have time to troubleshoot it as im working remotely.
Re: empty precreated templates?!?! [message #32238 is a reply to message #31902] Mon, 28 July 2008 06:16 Go to previous message
dowdle is currently offline  dowdle
Messages: 261
Registered: December 2005
Location: Bozeman, Montana
Senior Member
I haven't used SUSE, Novell, nor OpenSUSE as a host node nor have I created containers using those distros... so I'm not sure as to your specifics... but generally speaking...

Many of the pre-created OS Templates are extremely trimmed down to make them small to download and quick to install... and low on resource usage... with less software that requires updating. So, I would think your situation is normal. Just look at the size of the OS Templates you are using and ask... how much software would fit in there... and how does it compare to the install media in size? If it is considerably smaller than the distro's install media, it has been trimmed down.

Most of the OS Templates I have contributed are fairly bloated with software that I like... including yum.

I personally haven't really seen a whole lot of SUSE related OpenVZ activity and encourage you to become more proficient with OpenVZ and create some newer, more complete OS Templates and contribute them.


--
TYL, Scott Dowdle
Belgrade, Montana, USA
Previous Topic: problems with the kernel installation..
Next Topic: VEs cannot find DHCP server
Goto Forum:
  


Current Time: Mon Apr 22 10:18:35 GMT 2024

Total time taken to generate the page: 0.01211 seconds