OpenVZ Forum


Home » General » Support » performance loss after update
performance loss after update [message #5463] Sun, 20 August 2006 22:41 Go to next message
hemry is currently offline  hemry
Messages: 11
Registered: May 2006
Junior Member
Recently I updated to the last SUSE development kernel available vmlinuz-2.6.16.13-026test012-2-smp (I need 2.6.16 for some drivers) from vmlinuz-2.6.16-026test007-15-smp and I noticed huge increase in cpu consumption, after investigating I found that one of the cpus are used by "init"

# ps aux | grep init
root 1 0.0 0.0 740 284 ? S 01:07 0:01 init [3]
root 6798 0.0 0.0 25732 1360 ? Ss 01:07 0:00 /usr/sbin/sshd -o PidFile=/var/run/sshd.init.pid
root 8700 0.0 0.0 744 280 ? Ss 01:07 0:00 init
root 8767 0.0 0.0 744 284 ? Ss 01:07 0:00 init
root 9214 0.0 0.0 744 284 ? Ss 01:07 0:00 init
root 14484 0.0 0.0 740 284 ? Ss 01:13 0:00 init
root 15272 99.6 0.0 744 276 ? Rs 01:13 19:21 init
root 17372 0.0 0.0 2920 696 pts/0 R+ 01:33 0:00 grep init

here's the loop what systrace shows on it
write(0, "\nEnter runlevel: ", 17)      = 17
read(0, "", 8)                          = 0
write(0, "\nEnter runlevel: ", 17)      = 17
read(0, "", 8)                          = 0
write(0, "\nEnter runlevel: ", 17)      = 17
read(0, "", 8)                          = 0
write(0, "\nEnter runlevel: ", 17)      = 17
read(0, "", 8)                          = 0
write(0, "\nEnter runlevel: ", 17)      = 17
read(0, "", 8)                          = 0
write(0, "\nEnter runlevel: ", 17)      = 17
read(0, "", 8)                          = 0
write(0, "\nEnter runlevel: ", 17)      = 17
read(0, "", 8)                          = 0
write(0, "\nEnter runlevel: ", 17)      = 17
read(0, "", 8)                          = 0
write(0, "\nEnter runlevel: ", 17)      = 17


Is this openvz or my configuration issue?

[Updated on: Mon, 21 August 2006 08:11] by Moderator

Report message to a moderator

Re: performance loss after update [message #5523 is a reply to message #5463] Tue, 22 August 2006 12:32 Go to previous message
dev is currently offline  dev
Messages: 1693
Registered: September 2005
Location: Moscow
Senior Member

1. we updated SUSE kernel
http://openvz.org/download/kernel/suse10/

2. it is unlikely kernel problem. but who knows.
try to find what file descriptor 0 is.
for doing so try:
host# ls -la /proc/<init-pid>/fd


http://static.openvz.org/userbars/openvz-developer.png
Previous Topic: *SOLVED* VPS has no IP after reboot and /etc/rc.d/vz start...
Next Topic: Howto install vzyum using debian sarge host-node
Goto Forum:
  


Current Time: Wed Apr 17 07:08:40 GMT 2024

Total time taken to generate the page: 0.01346 seconds