OpenVZ Forum


Home » General » Support » ploop and vzctl yum errors
ploop and vzctl yum errors [message #48049] Wed, 26 September 2012 13:18 Go to next message
mangelot is currently offline  mangelot
Messages: 14
Registered: January 2012
Junior Member
I'm receiving errors after yum update proces.


Quote:
yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.oxilion.nl
* dag-extra: www.mirrorservice.org
* epel: mirror.nl.leaseweb.net
* extras: mirror.oxilion.nl
* openvz-kernel-rhel5: openvz.proserve.nl
* openvz-utils: openvz.proserve.nl
* updates: mirror.oxilion.nl
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ploop.i386 0:1.5-1 set to be updated
---> Package ploop-lib.i386 0:1.5-1 set to be updated
---> Package vzctl.i386 0:4.0-1 set to be updated
--> Processing Dependency: libcgroup.so.1 for package: vzctl
---> Package vzctl-core.i386 0:4.0-1 set to be updated
--> Processing Dependency: libcgroup.so.1(CGROUP_0.35) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1(CGROUP_0.32.1) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1(CGROUP_0.32) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1(CGROUP_0.34) for package: vzctl-core
--> Processing Dependency: libcgroup.so.1 for package: vzctl-core
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Finished Dependency Resolution
vzctl-core-4.0-1.i386 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.35) is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
vzctl-core-4.0-1.i386 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.32.1) is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
vzctl-core-4.0-1.i386 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1 is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
ploop-lib-1.5-1.i386 from openvz-utils has depsolving problems
--> ploop-lib conflicts with ovzkernel
ploop-lib-1.5-1.i386 from openvz-utils has depsolving problems
--> ploop-lib conflicts with ovzkernel-PAE
vzctl-4.0-1.i386 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1 is needed by package vzctl-4.0-1.i386 (openvz-utils)
vzctl-core-4.0-1.i386 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.34) is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
vzctl-core-4.0-1.i386 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.32) is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1 is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
Error: ploop-lib conflicts with ovzkernel
Error: Missing Dependency: libcgroup.so.1 is needed by package vzctl-4.0-1.i386 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.35) is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.34) is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32.1) is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
Error: ploop-lib conflicts with ovzkernel-PAE
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32) is needed by package vzctl-core-4.0-1.i386 (openvz-utils)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest


If i want to install libcgroup throught yum
yum install libcgroup

Quote:
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.oxilion.nl
* dag-extra: www.mirrorservice.org
* epel: mirror.nl.leaseweb.net
* extras: mirror.oxilion.nl
* openvz-kernel-rhel5: openvz.proserve.nl
* openvz-utils: openvz.proserve.nl
* updates: mirror.oxilion.nl
Excluding Packages in global exclude list
Finished
Setting up Install Process
No package libcgroup available.
Nothing to do


Is there no package libcgroup-(devel) for centos 5.8 release?
or is it only available for centos 6?


regards, Marco


www.mangelot-hosting.nl
Re: ploop and vzctl yum errors [message #48053 is a reply to message #48049] Wed, 26 September 2012 15:43 Go to previous messageGo to next message
jck9 is currently offline  jck9
Messages: 2
Registered: September 2012
Junior Member
I have the same problem at CentOS 6.3

Quote:

Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-279.9.1.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-279.5.2.el6 will be updated
---> Package kernel-firmware.noarch 0:2.6.32-279.9.1.el6 will be an update
---> Package ploop.x86_64 0:1.4-1 will be updated
---> Package ploop.x86_64 0:1.5-1 will be an update
---> Package ploop-lib.x86_64 0:1.4-1 will be updated
---> Package ploop-lib.x86_64 0:1.5-1 will be an update
---> Package vzctl.x86_64 0:3.3-1 will be updated
---> Package vzctl.x86_64 0:4.0-1 will be an update
--> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl-4.0-1.x86_64
---> Package vzctl-core.x86_64 0:4.0-1 will be obsoleting
---> Package vzctl-lib.x86_64 0:3.3-1 will be obsoleted
--> Running transaction check
---> Package libcgroup.x86_64 0:0.37-4.el6 will be installed
--> Processing Conflict: ploop-lib-1.5-1.x86_64 conflicts vzkernel < 2.6.32-042stab061.1
--> Finished Dependency Resolution
Error: ploop-lib conflicts with vzkernel
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest



And the same problem at CentOS 5.8

Quote:

--> Finished Dependency Resolution
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
vzctl-core-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
--> ploop-lib conflicts with ovzkernel
vzctl-4.0-1.x86_64 from openvz-utils has depsolving problems
--> Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-4.0-1.x86_64 (openvz-utils)
Error: ploop-lib conflicts with ovzkernel
Error: Missing Dependency: libcgroup.so.1()(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.34)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32.1)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.35)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)
Error: Missing Dependency: libcgroup.so.1(CGROUP_0.32)(64bit) is needed by package vzctl-core-4.0-1.x86_64 (openvz-utils)



Any ideas?
Re: ploop and vzctl yum errors [message #48056 is a reply to message #48053] Wed, 26 September 2012 16:30 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: N├╝rnberg, Germany
Senior Member

Remove old unused OpenVZ kernels:

see http://bugzilla.openvz.org/2369

Bye,
Thorsten
Re: ploop and vzctl yum errors [message #48058 is a reply to message #48056] Wed, 26 September 2012 17:38 Go to previous messageGo to next message
jck9 is currently offline  jck9
Messages: 2
Registered: September 2012
Junior Member
Thank you for your advice, it helped with CentOS 6.3, but it didn't help with CentOS 5.8, still looking for solution to resolve this case (


Re: ploop and vzctl yum errors [message #48085 is a reply to message #48049] Thu, 27 September 2012 04:44 Go to previous messageGo to next message
Ales is currently offline  Ales
Messages: 330
Registered: May 2009
Senior Member
You really should open a bug ticket about libcgroup dependency on Centos 5.x (if it doesn't exist already). I believe the devs know about this but never the less, a bug is good for tracking such things.

Sorry for not being able to be more constructive at this time.

[Updated on: Thu, 27 September 2012 05:00]

Report message to a moderator

Re: ploop and vzctl yum errors [message #48088 is a reply to message #48085] Thu, 27 September 2012 08:29 Go to previous messageGo to next message
Bodysplit is currently offline  Bodysplit
Messages: 20
Registered: July 2007
Junior Member
My EL5 machine is also running into this problem since the updated packages vzctl 4.0 and ploop 1.5.

My findings: the required CPU groups in libcgroup was added to kernel 2.6.24 and later. It is not available in the EL5 2.6.18.

So unless the ovz kernel has this backported, this cgroup dependency will never happen. The libcgroup rpm's I could find were all for EL6.

For now I decided to yum versionlock the old vzctl / ploop-versions to get rid of the error message.

Is this the end of EL5 support?



--
This doesn't look comfortable...
Re: ploop and vzctl yum errors [message #48089 is a reply to message #48049] Thu, 27 September 2012 09:28 Go to previous messageGo to next message
Ales is currently offline  Ales
Messages: 330
Registered: May 2009
Senior Member
Kernel versions between vanilla and Red Hat kernels aren't directly comparable, as RH backports many newer additions into seemingly older kernel versions.

But, sadly, cgroups isn't likely to ever land in RHEL 5. OpenVZ will need to find a way around this if they intend to keep a single tools repository for both RHEL 5 an 6.

It's a bit odd they didn't catch this dependency issue before the release...
Re: ploop and vzctl yum errors [message #48095 is a reply to message #48049] Thu, 27 September 2012 12:21 Go to previous messageGo to next message
sidd is currently offline  sidd
Messages: 9
Registered: September 2012
Location: india
Junior Member
Hi ,

I am able to fix the issue by adding libcgroup-0.37-1 rpm .

Also we have to compile it for centos 5 as package is not aviable for centos 5 .

Steps to compile it are as below :-

Download source rpm from here :-
ftp://ftp.pbone.net/mirror/ftp.redhat.com/pub/redhat/linux/enterprise/6Client/en/os/SRPMS/libcgroup-0.37-4.el6.src.rpm

Extract it using zip7 on windows also extract the cpio file you will get source :-

Then upload the expracted source directory it to your server . 

Install this packages:-
yum install pam-devel byacc flex coreutils shadow-utils make gcc rpm-build gcc-c++ -y

Go in the source directory and run this command :-
rpmbuild -ta libcgroup-0.37.tar.bz2
Re: ploop and vzctl yum errors [message #48107 is a reply to message #48058] Thu, 27 September 2012 14:22 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

I have added libcgroup to repository, so it should be resolved now.

Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Re: ploop and vzctl yum errors [message #48115 is a reply to message #48107] Thu, 27 September 2012 15:55 Go to previous messageGo to next message
Bodysplit is currently offline  Bodysplit
Messages: 20
Registered: July 2007
Junior Member
libcgroup is installed now, but does not seem to help.

kernel 2.6.18 is now to old for ploop-lib.

Resolving Dependencies
--> Running transaction check
--> Processing Dependency: ploop-lib = 1.4 for package: ploop
---> Package ploop-lib.x86_64 0:1.5-1 set to be updated
---> Package vzctl-core.x86_64 0:4.0-1 set to be updated
--> Processing Dependency: libvzctl-3.3.so()(64bit) for package: vzctl
--> Processing Dependency: vzctl-lib = 3.3-1 for package: vzctl
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Finished Dependency Resolution
vzctl-3.3-1.x86_64 from installed has depsolving problems
  --> Missing Dependency: libvzctl-3.3.so()(64bit) is needed by package vzctl-3.3-1.x86_64 (installed)
ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
  --> ploop-lib conflicts with ovzkernel
vzctl-3.3-1.x86_64 from installed has depsolving problems
  --> Missing Dependency: vzctl-lib = 3.3-1 is needed by package vzctl-3.3-1.x86_64 (installed)
ploop-1.4-1.x86_64 from installed has depsolving problems
  --> Missing Dependency: ploop-lib = 1.4 is needed by package ploop-1.4-1.x86_64 (installed)
Error: Missing Dependency: vzctl-lib = 3.3-1 is needed by package vzctl-3.3-1.x86_64 (installed)
Error: ploop-lib conflicts with ovzkernel
Error: Missing Dependency: ploop-lib = 1.4 is needed by package ploop-1.4-1.x86_64 (installed)
Error: Missing Dependency: libvzctl-3.3.so()(64bit) is needed by package vzctl-3.3-1.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


package-cleanup and rpm run without error.


--
This doesn't look comfortable...
Re: ploop and vzctl yum errors [message #48116 is a reply to message #48049] Thu, 27 September 2012 16:20 Go to previous messageGo to next message
sidd is currently offline  sidd
Messages: 9
Registered: September 2012
Location: india
Junior Member
Hi ,

Resolving Dependencies
--> Running transaction check
--> Processing Dependency: ploop-lib = 1.4 for package: ploop
---> Package ploop-lib.x86_64 0:1.5-1 set to be updated
---> Package vzctl-core.x86_64 0:4.0-1 set to be updated
--> Processing Dependency: libvzctl-3.3.so()(64bit) for package: vzctl
--> Processing Dependency: vzctl-lib = 3.3-1 for package: vzctl
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Finished Dependency Resolution
vzctl-3.3-1.x86_64 from installed has depsolving problems
  --> Missing Dependency: libvzctl-3.3.so()(64bit) is needed by package vzctl-3.3-1.x86_64 (installed)
ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
  --> ploop-lib conflicts with ovzkernel
vzctl-3.3-1.x86_64 from installed has depsolving problems
  --> Missing Dependency: vzctl-lib = 3.3-1 is needed by package vzctl-3.3-1.x86_64 (installed)
ploop-1.4-1.x86_64 from installed has depsolving problems
  --> Missing Dependency: ploop-lib = 1.4 is needed by package ploop-1.4-1.x86_64 (installed)
Error: Missing Dependency: vzctl-lib = 3.3-1 is needed by package vzctl-3.3-1.x86_64 (installed)
Error: ploop-lib conflicts with ovzkernel
Error: Missing Dependency: ploop-lib = 1.4 is needed by package ploop-1.4-1.x86_64 (installed)
Error: Missing Dependency: libvzctl-3.3.so()(64bit) is needed by package vzctl-3.3-1.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Have you enable vz repo for centos 5
Re: ploop and vzctl yum errors [message #48117 is a reply to message #48116] Thu, 27 September 2012 16:31 Go to previous messageGo to next message
Bodysplit is currently offline  Bodysplit
Messages: 20
Registered: July 2007
Junior Member
yes, repo is active and the dependencies listed are missleading.

[root@bart ~]# yum list installed | grep vzctl
vzctl.x86_64                         3.3-1                             installed
vzctl-lib.x86_64                     3.3-1                             installed


and:
[root@bart ~]# yum list installed | grep ploop
ploop.x86_64                         1.4-1                             installed
ploop-lib.x86_64                     1.4-1                             installed


The main issue seems to be the conflicting kernel version. And it seems that the switch to cgroup's was not a good idea, as it did break backwards compatibility.


--
This doesn't look comfortable...
Re: ploop and vzctl yum errors [message #48118 is a reply to message #48115] Thu, 27 September 2012 16:33 Go to previous messageGo to next message
sidd is currently offline  sidd
Messages: 9
Registered: September 2012
Location: india
Junior Member
Hi ,

kir thnxs .
I had tested it works .
Re: ploop and vzctl yum errors [message #48119 is a reply to message #48117] Thu, 27 September 2012 16:48 Go to previous messageGo to next message
sidd is currently offline  sidd
Messages: 9
Registered: September 2012
Location: india
Junior Member
Hi ,

Remove the old kernel .

Using yum remove ovzkernel vzctl vzquota

Which will remove the old kernel and try reinstalling new one
Re: ploop and vzctl yum errors [message #48128 is a reply to message #48049] Fri, 28 September 2012 21:09 Go to previous messageGo to next message
breun is currently offline  breun
Messages: 2
Registered: November 2011
Junior Member
There is no newer OpenVZ kernel than ovzkernel-2.6.18-308.8.2.el5.028stab101.1 for EL5 right now, so the dependency can't be resolved.
Re: ploop and vzctl yum errors [message #48129 is a reply to message #48119] Sat, 29 September 2012 04:34 Go to previous messageGo to next message
ccto is currently offline  ccto
Messages: 61
Registered: October 2005
Member
A stupid question?

Do we remove the running ovzkernel (2.6.18-308.8.2.el5.028stab101.1) too?

I am using SSH remote-control the server... Sad

[root@xxx ~]# uname -r
2.6.18-308.8.2.el5.028stab101.1
[root@xxx ~]# rpm -qa | grep kernel | sort
kernel-headers-2.6.18-308.13.1.el5
ovzkernel-2.6.18-308.8.2.el5.028stab101.1
ovzkernel-devel-2.6.18-308.8.2.el5.028stab101.1
[root@xxx ~]# yum -y update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.01link.hk
 * extras: centos.ustc.edu.cn
 * openvz-kernel-rhel5: mirror.secureax.com
 * openvz-utils: mirror.secureax.com
 * rpmforge: mirror.oscc.org.my
 * updates: centos.01link.hk
Reducing Red Hat Enterprise 5 - RPMforge.net - dag to included packages only
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package bind-libs.x86_64 30:9.3.6-20.P1.el5_8.4 set to be updated
---> Package bind-utils.x86_64 30:9.3.6-20.P1.el5_8.4 set to be updated
---> Package libxml2.x86_64 0:2.6.26-2.1.15.el5_8.5 set to be updated
---> Package libxml2-python.x86_64 0:2.6.26-2.1.15.el5_8.5 set to be updated
---> Package ploop.x86_64 0:1.5-1 set to be updated
---> Package ploop-lib.x86_64 0:1.5-1 set to be updated
---> Package postgresql-libs.x86_64 0:8.1.23-6.el5_8 set to be updated
---> Package sudo.x86_64 0:1.7.2p1-14.el5_8.4 set to be updated
---> Package vzctl.x86_64 0:4.0-1 set to be updated
--> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl
---> Package vzctl-core.x86_64 0:4.0-1 set to be updated
--> Running transaction check
---> Package libcgroup.x86_64 0:0.38-1 set to be updated
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Finished Dependency Resolution
ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
  --> ploop-lib conflicts with ovzkernel
Error: ploop-lib conflicts with ovzkernel
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@xxx ~]#
Re: ploop and vzctl yum errors [message #48130 is a reply to message #48049] Sat, 29 September 2012 05:13 Go to previous messageGo to next message
umask is currently offline  umask
Messages: 23
Registered: December 2007
Junior Member
I'm too can't update my centos 5.8 installation due to conflict:

Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1


This problem happened more than one week ago and still present.


Full yum output:

# yum update
Loaded plugins: downloadonly, fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.softaculous.com
* extras: ftp.halifax.rwth-aachen.de
* openvz-kernel-rhel5: mirror.softaculous.com
* openvz-utils: mirror.softaculous.com
* updates: mirror.softaculous.com
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ploop.x86_64 0:1.5-1 set to be updated
---> Package ploop-lib.x86_64 0:1.5-1 set to be updated
---> Package vzctl.x86_64 0:4.0-1 set to be updated
--> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl
---> Package vzctl-core.x86_64 0:4.0-1 set to be updated
--> Running transaction check
---> Package libcgroup.x86_64 0:0.38-1 set to be updated
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
--> Finished Dependency Resolution
ploop-lib-1.5-1.x86_64 from openvz-utils has depsolving problems
--> ploop-lib conflicts with ovzkernel
Error: ploop-lib conflicts with ovzkernel
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
Re: ploop and vzctl yum errors [message #48131 is a reply to message #48129] Sat, 29 September 2012 10:43 Go to previous messageGo to next message
breun is currently offline  breun
Messages: 2
Registered: November 2011
Junior Member
There is no newer kernel available for EL5. If there was, yum would tell you. Removing your current kernels is not going to help on EL5, the new vzctl/ploop packages are just currently not compatible with EL5 it seems.
Re: ploop and vzctl yum errors [message #48134 is a reply to message #48130] Sat, 29 September 2012 14:16 Go to previous messageGo to next message
Paparaciz
Messages: 302
Registered: August 2009
Senior Member
http://openvz.org/pipermail/users/2012-September/004921.html
Re: ploop and vzctl yum errors [message #48195 is a reply to message #48134] Wed, 03 October 2012 06:28 Go to previous messageGo to next message
DeepM is currently offline  DeepM
Messages: 14
Registered: December 2009
Location: Lithuania
Junior Member
Looks like for CentOS6 you must have latest kernel.
For CentOS5 you must remove ploop and ploop-lib packages (ofcourse if You don't use ploop for containers).
For now on CentOS5 server i have:

yum list |grep vz
* openvz-kernel-rhel5: mirror.duomenucentras.lt
* openvz-utils: mirror.duomenucentras.lt
ovzkernel.x86_64 2.6.18-308.8.2.el5.028stab101.1
vzctl.x86_64 4.0-1 installed
vzctl-core.x86_64 4.0-1 installed
vzquota.x86_64 3.1-1 installed
Re: ploop and vzctl yum errors [message #48198 is a reply to message #48195] Wed, 03 October 2012 10:05 Go to previous messageGo to next message
Bodysplit is currently offline  Bodysplit
Messages: 20
Registered: July 2007
Junior Member
So, ploop does currently work only with EL6?

As there is now upgrade path for EL5 to EL6 this results in ploop is only available on newer hardware (where it makes sense to directly install EL6).

I thought I could try ploop with EL5, but I didn't even migrated ext3 to 4 which seems to be another requirement for ploop.

Time to buy some new servers...


--
This doesn't look comfortable...
Re: ploop and vzctl yum errors [message #48221 is a reply to message #48049] Mon, 08 October 2012 07:11 Go to previous message
ccto is currently offline  ccto
Messages: 61
Registered: October 2005
Member

F.Y.I.

I tried to run the following in CentOS 5 x64

yum erase ploop ploop-lib vzctl vzctl-lib 

yum install vzctl.x86_64 vzctl-core.x86_64

yum update


It finally can complete the yum update process without error.
Previous Topic: nearly all memory shows as cached
Next Topic: Trouble setting up DHCP addresses
Goto Forum:
  


Current Time: Tue Oct 03 18:34:02 GMT 2023

Total time taken to generate the page: 0.02712 seconds