OpenVZ Forum


Home » General » Support » kernel: unregister_netdevice: waiting for lo to become free.
kernel: unregister_netdevice: waiting for lo to become free. [message #36299] Sun, 07 June 2009 01:49 Go to next message
acenetBD is currently offline  acenetBD
Messages: 2
Registered: June 2009
Junior Member
Occasionally when shutting down VEs the following messages are displayed during shutdown:

kernel: unregister_netdevice: waiting for lo=xxxxxxxx to become free. Usage count = 3 ve=xxx

kernel: unregister_netdevice: device xxxxxxxx marked to leak

kernel: free_netdev: device lo=xxxxxxxx leaked


The VE is then successfully stopped/unmounted.

The last time that this particular HWNode was rebooted, these messages occurred for every VE on the Node. The Node's shutdown process eventually hung and the Node had to be hardbooted.

There are a few older topics on this subject which indicate a kernel bug. This node is however is running the latest available CentOS 5 kernel:

2.6.18-028stab062.3-ent

and those messages still persist.

Individual environments do shutdown eventually after the 'unregister_netdevice' and 'free_netdev' messages, but I'm wondering if anyone has any insight as to what's causing them.

Also wondering if anyone's had a similar issue when rebooting a HWNode and having it hang after these messages occur for every VE and how it was resolved.

Thanks
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #36306 is a reply to message #36299] Mon, 08 June 2009 07:37 Go to previous messageGo to next message
maratrus is currently offline  maratrus
Messages: 1495
Registered: August 2007
Location: Moscow
Senior Member
The most important (and i suppose the only thing we need at the moment for this issue) is a testcase.
If you find a testcase that reproduces this issue, please, file a bug and post it, otherwise please, don't worry about it, assume this is a warning. But if this issue can lead to any side-effects, e.g. hanging, crashing etc don't hesitate to file a new bug report into bugzilla http://bugzilla.openvz.org/
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #36332 is a reply to message #36299] Wed, 10 June 2009 22:38 Go to previous messageGo to next message
seanfulton is currently offline  seanfulton
Messages: 105
Registered: May 2007
Senior Member
I have the same problem with the 2.6.18-128.1.1.el5.028stab062.3PAE
kernel. Happens on ALL VEs. The problem is that it eventually hangs the machine and has to be power-cycled.

I think this is new. I don't recall having this problem on earlier kernels, although I can't say specifically when it started.


sean
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #36441 is a reply to message #36299] Thu, 18 June 2009 15:19 Go to previous messageGo to next message
schogge is currently offline  schogge
Messages: 19
Registered: July 2007
Junior Member
Same problem here.

2.6.18-128.1.1.el5.028stab062.3ent #1 SMP Tue May 5 18:09:38 MSD 2009 i686 athlon i386 GNU/Linux


Quote:

I think this is new. I don't recall having this problem on earlier kernels

Same for me.
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #36505 is a reply to message #36299] Fri, 26 June 2009 10:31 Go to previous messageGo to next message
nokoya is currently offline  nokoya
Messages: 4
Registered: June 2009
Junior Member
same here on 2.6.18-128.1.1.el5.028stab062.3 #1 SMP Sun May 10 18:54:51 MSD 2009 x86_64 x86_64 x86_64 GNU/Linux
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #36901 is a reply to message #36505] Tue, 28 July 2009 20:44 Go to previous messageGo to next message
luispt is currently offline  luispt
Messages: 3
Registered: July 2009
Junior Member
Hello,

I'm having the same problem. Any fix for this?

thanks

[Updated on: Tue, 28 July 2009 20:45]

Report message to a moderator

Re: kernel: unregister_netdevice: waiting for lo to become free. [message #37009 is a reply to message #36299] Tue, 11 August 2009 07:12 Go to previous messageGo to next message
disaster is currently offline  disaster
Messages: 158
Registered: February 2006
Senior Member
Has anyone tested if it is fixed with the newest kernel?
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #37057 is a reply to message #37009] Sun, 16 August 2009 06:08 Go to previous messageGo to next message
aoscentral is currently offline  aoscentral
Messages: 29
Registered: November 2008
Junior Member
disaster wrote on Tue, 11 August 2009 03:12
Has anyone tested if it is fixed with the newest kernel?


Hello ,

I had This problem to , I've installed latest kernel"2.6.18-128.2.1.el5.028stab064.4" . It look , The problem solved !

Regards ,
Mohsen
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #37160 is a reply to message #36299] Mon, 24 August 2009 04:21 Go to previous messageGo to next message
acenetBD is currently offline  acenetBD
Messages: 2
Registered: June 2009
Junior Member
This seems to be resolved in the 2.6.18-028stab064.4-ent kernel as well.
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #38964 is a reply to message #37160] Wed, 24 February 2010 20:21 Go to previous messageGo to next message
alevchuk is currently offline  alevchuk
Messages: 22
Registered: February 2007
Location: University of California,...
Junior Member
I have
2.6.26.8+openvz-dostoevsky
vzctl version 3.0.23

My HN gets stuck on shut down, with only this message:
"""
unregistered device: waiting for vzbr0 to become free. Usage count = 1
"""

Message keeps repeating every few second forever.

Alex
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #38966 is a reply to message #38964] Wed, 24 February 2010 20:26 Go to previous messageGo to next message
aoscentral is currently offline  aoscentral
Messages: 29
Registered: November 2008
Junior Member
Hello ,

Please attach the /var/log/messages

Thank you
Re: kernel: unregister_netdevice: waiting for lo to become free. [message #38967 is a reply to message #38966] Wed, 24 February 2010 20:38 Go to previous message
alevchuk is currently offline  alevchuk
Messages: 22
Registered: February 2007
Location: University of California,...
Junior Member
I saw about 10 prints of "unregistered device: waiting" on the display when I was physically in the data center.

Attached is all that got into /var/log/messages during shut-down.

Thank you

[Updated on: Fri, 26 February 2010 00:38]

Report message to a moderator

Previous Topic: online migration failed > unsupported netdevice gre0
Next Topic: dual NIC
Goto Forum:
  


Current Time: Sat May 18 03:15:11 GMT 2024

Total time taken to generate the page: 0.01504 seconds