OpenVZ Forum


Home » General » Support » Network issue
Network issue [message #32862] Wed, 03 September 2008 19:28 Go to next message
timpickup is currently offline  timpickup
Messages: 1
Registered: September 2008
Junior Member
Hi,

I cant get my container to access or be accessed by the internet.

I have done some reading but not managed to work out the solution.

Both container and host have public ips.

I have added the public ip to the container with vzctl set 1 --ipadd

Im guessing the issue may be because the Primary public ip address on the host is on a different subnet than the containers public ip.

Any pointers ?

Thanks
Re: Network issue [message #32873 is a reply to message #32862] Fri, 05 September 2008 16:51 Go to previous message
Night Nord is currently offline  Night Nord
Messages: 4
Registered: July 2008
Location: Russia, SPb
Junior Member

Creating VPSes with VEIDs less than 100 not recommended, as they could be used for internal purposes.

Such problem could happen if you have wrong/missing routing table on both VE/HN. Please, provide more information:
1) `ip route` on both VE and HN
2) `ip --version` on VE
3) 'uname -r' on HN
4) Try to ping VE from HN and vica-versa. Results?
5) Have you firewall enabled on HN?
6) Have you ip_forwarding enabled? (Post `sysctl -p` from HN)
Previous Topic: Kernelspace L2TP (using openl2tpd) inside VE - PPPOX socket fail
Next Topic: *SOLVED* disable ipv6
Goto Forum:
  


Current Time: Sat Mar 02 13:02:09 GMT 2024

Total time taken to generate the page: 0.02509 seconds