OpenVZ Forum


Home » General » Support » ls: reading directory .: Input/output error
ls: reading directory .: Input/output error [message #28755] Fri, 28 March 2008 00:16 Go to next message
douglas is currently offline  douglas
Messages: 14
Registered: October 2005
Junior Member
Greetings,

I'm hosting a gallery (http://gallery.menalto.com/) for my family and the directory that it stores its data in is called entity.

However, for some reason inside my vz I can't do an ls or a tar on the directory without getting an error. I have shutdown apache and mysql and still get the error.

box1:/home/steve/entity/2/2# ls -al
ls: reading directory .: Input/output error
total 728

tar complains about the bad descriptor and corruption.

The gallery works fine and are no problems. I think this maybe a vz problem.

Linux box1 2.6.8-022stab070.1-enterprise #1 SMP Mon Feb 20 19:31:28 MSK 2006 i686 GNU/Linux

I want to upgrade the machine and move it over to another server but I can't finish rsyncing my vz because of this. Any help would be appreciated.



Re: ls: reading directory .: Input/output error [message #28792 is a reply to message #28755] Fri, 28 March 2008 12:12 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

Is there anything related in dmesg output?

I'm afraid this looks like a hardware (HDD) failure -- in this case in dmesg you will see errors like "unable to read sector" or smth.

I suggest you to copy as much data as possible from this HDD and replace it (or restore from last good backup to a new drive).


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Re: ls: reading directory .: Input/output error [message #28817 is a reply to message #28755] Sat, 29 March 2008 03:15 Go to previous messageGo to next message
douglas is currently offline  douglas
Messages: 14
Registered: October 2005
Junior Member
I have other vz's on this box and its hardware raided.... dmesg doesn't show anything, I'm running debian.
Re: ls: reading directory .: Input/output error [message #28820 is a reply to message #28817] Sat, 29 March 2008 09:44 Go to previous message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

Then I suggest you to stop all containers, umount /vz and run fsck on it.

Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Previous Topic: CPUUNITS over 500000 not possible ? vzcpucheck problem ?
Next Topic: /* SOLVED */ My First VPS !
Goto Forum:
  


Current Time: Tue Feb 27 13:51:20 GMT 2024

Total time taken to generate the page: 0.02602 seconds