Quoting Cedric Le Goater (clg@fr.ibm.com):
> all,
>
> 'pspace' sounds wrong when you know about the other namespaces :
>
> struct nsproxy {
> atomic_t count;
> spinlock_t nslock;
> struct uts_namespace *uts_ns;
> struct ipc_namespace *ipc_ns;
> struct user_namespace *user_ns;
> struct namespace *namespace;
> };
>
> 'proc_namespace' might be confusing, what about 'task_namespace' ?
>
> 'namespace' should probably be renamed to something like 'mnt_namespace' ?
pid_ns and mnt_ns?
(task_ns is not quite correct, since the task_struct relationships, i.e.
parent->child and session/group, are not really part of the namespace)
Wonder whether Al would have a cow if we rename 'namespace' to
'mnt_ns'...
-serge
_______________________________________________
Containers mailing list
Containers@lists.osdl.org
https://lists.osdl.org/mailman/listinfo/containers