OpenVZ Forum


Home » Mailing lists » Devel » Re: pspace name
Re: pspace name [message #16598] Thu, 07 September 2006 16:10 Go to previous message
Sukadev Bhattiprolu is currently offline  Sukadev Bhattiprolu
Messages: 413
Registered: August 2006
Senior Member
Cedric Le Goater [clg@fr.ibm.com] wrote:
| all,
| 
| 'pspace' sounds wrong when you know about the other namespaces :
| 
| struct nsproxy {
| 	atomic_t count;
| 	spinlock_t nslock;
| 	struct uts_namespace *uts_ns;
| 	struct ipc_namespace *ipc_ns;
| 	struct user_namespace *user_ns;
| 	struct namespace *namespace;
| };
| 
| 'proc_namespace' might be confusing, what about 'task_namespace' ?

I agree we should rename.  I had suggested pid_space to "rhyme" wiht
pidmap, but received no ack/nack. I meant to send another mail,
specially after the is_init() collision recently.
| 
| 'namespace' should probably be renamed to something like 'mnt_namespace' ?

While at it, should we change CLONE_NEWNS to CLONE_MNTNS ?
| 
| C.
| _______________________________________________
| Containers mailing list
| Containers@lists.osdl.org
| https://lists.osdl.org/mailman/listinfo/containers
_______________________________________________
Containers mailing list
Containers@lists.osdl.org
https://lists.osdl.org/mailman/listinfo/containers
 
Read Message
Read Message
Read Message
Previous Topic: Re: [ckrm-tech] [PATCH] BC: resource beancounters (v4) (added user memory)
Next Topic: [PATCH] file: Add locking to f_getown
Goto Forum:
  


Current Time: Sat Aug 30 18:06:51 GMT 2025

Total time taken to generate the page: 0.10814 seconds