Re: [PATCH] Introduce a handy list_first_entry macro [message #12168 is a reply to message #12078] |
Wed, 18 April 2007 11:42  |
Nikita Danilov
Messages: 1 Registered: April 2007
|
Junior Member |
|
|
Pavel Emelianov writes:
> There are many places in the kernel where the construction like
>
> foo = list_entry(head->next, struct foo_struct, list);
>
> are used.
> The code might look more descriptive and neat if using the macro
>
> list_first_entry(head, type, member) \
> list_entry((head)->next, type, member)
Won't list_next_entry() be more descriptive name for that?
Nikita.
|
|
|