OpenVZ Forum


Home » Mailing lists » Devel » Re: pspace name
Re: pspace name [message #16598] Thu, 07 September 2006 16:10 Go to next message
Sukadev Bhattiprolu is currently offline  Sukadev Bhattiprolu
Messages: 413
Registered: August 2006
Senior Member
Cedric Le Goater [clg@fr.ibm.com] wrote:
| all,
| 
| 'pspace' sounds wrong when you know about the other namespaces :
| 
| struct nsproxy {
| 	atomic_t count;
| 	spinlock_t nslock;
| 	struct uts_namespace *uts_ns;
| 	struct ipc_namespace *ipc_ns;
| 	struct user_namespace *user_ns;
| 	struct namespace *namespace;
| };
| 
| 'proc_namespace' might be confusing, what about 'task_namespace' ?

I agree we should rename.  I had suggested pid_space to "rhyme" wiht
pidmap, but received no ack/nack. I meant to send another mail,
specially after the is_init() collision recently.
| 
| 'namespace' should probably be renamed to something like 'mnt_namespace' ?

While at it, should we change CLONE_NEWNS to CLONE_MNTNS ?
| 
| C.
| _______________________________________________
| Containers mailing list
| Containers@lists.osdl.org
| https://lists.osdl.org/mailman/listinfo/containers
_______________________________________________
Containers mailing list
Containers@lists.osdl.org
https://lists.osdl.org/mailman/listinfo/containers
Re: pspace name [message #16608 is a reply to message #16598] Thu, 07 September 2006 19:52 Go to previous messageGo to next message
ebiederm is currently offline  ebiederm
Messages: 1354
Registered: February 2006
Senior Member
Sukadev Bhattiprolu <sukadev@us.ibm.com> writes:

> I agree we should rename.  I had suggested pid_space to "rhyme" wiht
> pidmap, but received no ack/nack. I meant to send another mail,
> specially after the is_init() collision recently.
> | 
> | 'namespace' should probably be renamed to something like 'mnt_namespace' ?
>
> While at it, should we change CLONE_NEWNS to CLONE_MNTNS ?

We need to retain the NEW in the clone flags. CLONE_NEWMNTNS perhaps.
Otherwise with clone at least we get impression of backward semantics.

Eric
_______________________________________________
Containers mailing list
Containers@lists.osdl.org
https://lists.osdl.org/mailman/listinfo/containers
Re: pspace name [message #16647 is a reply to message #16608] Sat, 09 September 2006 04:11 Go to previous message
Herbert Poetzl is currently offline  Herbert Poetzl
Messages: 239
Registered: February 2006
Senior Member
On Thu, Sep 07, 2006 at 01:52:39PM -0600, Eric W. Biederman wrote:
> Sukadev Bhattiprolu <sukadev@us.ibm.com> writes:
> 
> > I agree we should rename.  I had suggested pid_space to "rhyme" wiht
> > pidmap, but received no ack/nack. I meant to send another mail,
> > specially after the is_init() collision recently.
> > | 
> > | 'namespace' should probably be renamed to something like
> > | 'mnt_namespace' ?

> > While at it, should we change CLONE_NEWNS to CLONE_MNTNS ?
> 
> We need to retain the NEW in the clone flags. CLONE_NEWMNTNS perhaps.
> Otherwise with clone at least we get impression of backward semantics.

hmm, got no comment to my suggestion to use VFS instead
of MNT or mount, was it silently ignored, disliked, or
just lost?

best,
Herbert

> Eric
> _______________________________________________
> Containers mailing list
> Containers@lists.osdl.org
> https://lists.osdl.org/mailman/listinfo/containers
_______________________________________________
Containers mailing list
Containers@lists.osdl.org
https://lists.osdl.org/mailman/listinfo/containers
Previous Topic: Re: [ckrm-tech] [PATCH] BC: resource beancounters (v4) (added user memory)
Next Topic: [PATCH] file: Add locking to f_getown
Goto Forum:
  


Current Time: Fri Aug 29 18:10:15 GMT 2025

Total time taken to generate the page: 0.12102 seconds